Blackboard Outage
Incident Report for Dental Informatics
Resolved
Blackboard is now back up and operational.
Posted Mar 10, 2023 - 12:03 EST
Update
We are continuing to investigate this issue.
Posted Mar 10, 2023 - 09:04 EST
Investigating
Blackboard has been reported to be down. Main IT staff members are handling the situation. We will provide updates as more information is provided to the DI team members.
Posted Mar 10, 2023 - 09:03 EST
This incident affected: Campus Network.