Audio Isn't Working in 367
Incident Report for Dental Informatics
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 14:48 EDT
Investigating
We are currently troubleshooting this issue with our vendor.
Posted Apr 03, 2024 - 16:28 EDT
This incident affected: DTL367.