Room 124 Lecture PC
Incident Report for Dental Informatics
Resolved
This incident has been resolved.
Posted Oct 03, 2023 - 14:42 EDT
Monitoring
The PC is functional again in Rm 124, please let us know if you encounter any issues. A new PC will be installed here in the next few days.
Posted Sep 19, 2023 - 12:39 EDT
Investigating
There is an issue with the pc in Room 124. Please stop by to borrow a loaner laptop, as we are currently working on replacing the pc.
Posted Sep 18, 2023 - 11:23 EDT
This incident affected: DTL124.