Citrix remote access issue
Incident Report for Dental Informatics
Resolved
Good morning. Remote access to the Citrix environment has been restored. If you encounter any issues with remote access, please reach out to Dental Informatics directly for assistance. Thank you.
Posted Sep 15, 2023 - 08:42 EDT
Investigating
We are currently investigating an issue with Citrix remote access wherein users are unable to launch their desktop. This issue is exclusive to remote access and on-site Citrix access is uninterrupted. We will provide updates on this issue as we progress through it.

-Dental Informatics
Posted Sep 14, 2023 - 19:25 EDT
This incident affected: Citrix XenDesktop/XenApp.