Room 124
Incident Report for Dental Informatics
Resolved
This incident has been resolved.
Posted Jan 26, 2024 - 16:40 EST
Update
We are continuing to investigate this issue.
Posted Jan 26, 2024 - 15:48 EST
Update
The issue with audio in Room 124 has been resolved. We apologize for any inconvenience.
Posted Jan 26, 2024 - 15:48 EST
Investigating
We are currently investigating the issue of no audio in Room 124 that has been reported. We will notify you once the issue is resolved. We apologize for any inconvenience this may cause.
Posted Jan 26, 2024 - 09:15 EST
This incident affected: DTL124.