Printer Issue
Incident Report for Dental Informatics
Resolved
This incident has been resolved.
Posted Apr 03, 2024 - 12:28 EDT
Investigating
We were just notified there's an issue printing to Canon Printers. We will update you all as soon as we can as we receive information from Main Campus ITS.
Posted Apr 03, 2024 - 11:55 EDT
This incident affected: Printing.